Elevated report loading errors in EU region

Incident Report for CustomerGauge

Resolved

This incident has been resolved. We’ve received confirmation from impacted customers that report loading is working as expected again.
Posted Mar 18, 2026 - 13:36 UTC

Update

The reoccurred issue has been resolved. We are continuing to monitor the results.
Posted Mar 18, 2026 - 13:23 UTC

Update

The issue has reoccurred for some customers in the EU region, causing elevated report loading errors. Our team is actively working on a fix and we’ll share another update soon.
Posted Mar 18, 2026 - 12:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 11:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 18, 2026 - 10:55 UTC

Investigating

We are seeing elevated error rates for report loads in the EU region affecting customers with Division Hierarchy filtering enabled. We have identified the cause and are working on a fix. We will share another update soon.
Posted Mar 18, 2026 - 10:54 UTC
This incident affected: Reporting.