CG Academy is currently Unavailable
Incident Report for CustomerGauge
Resolved
CG Academy is now available. Users are able to login.
Posted Apr 19, 2023 - 10:42 UTC
Investigating
CG Academy is currently unavailable. Users will not be able to login. We are working with our partner to address this.
Posted Apr 19, 2023 - 08:58 UTC
This incident affected: CG Academy.