Resolved - Email Delivery Restored

Incident Report for CustomerGauge

Resolved

The issue affecting email delivery for campaigns using Custom Email Sender Domains has been fully resolved.

Email delivery is operating normally, and we are currently reprocessing emails that previously failed with a "General Error" status during the incident. No action is required from customers.

We apologize for the inconvenience and thank you for your patience while we resolved this issue.
Posted Jul 10, 2026 - 12:29 UTC

Monitoring

The issue causing elevated email delivery errors for campaigns using Custom Email Sender Domains has been identified and resolved.

Email delivery has now returned to normal, and we keep monitoring the situation.

We apologize for the inconvenience and appreciate your patience.
Posted Jul 10, 2026 - 11:21 UTC

Investigating

We are currently investigating elevated error rates, starting at 3:00AM (Amsterdam time) affecting email delivery for campaigns using Custom Email Sender Domains. Impacted survey invitation emails may fail with a "General Error" status instead of being sent.

Our team is actively investigating the root cause and working to restore normal service as quickly as possible. We will provide another update as more information becomes available.

We apologize for the inconvenience and appreciate your patience.
Posted Jul 10, 2026 - 11:14 UTC
This incident affected: Email Sending.